[WF-General] A few issues with sear

Simon Goodall sg02r at ecs.soton.ac.uk
Wed Apr 11 06:07:22 PDT 2007



Alistair Riddoch wrote:
> I've had a few issues with sear recently.
> 
> Firstly, the warriors/merceneries near the origin show the contents of
> their inventory rendered on the ground at their feet. IIRC there is a
> flag for this in the media, but I don't recall where it is.
The object_records.cfg file should have draw_members = "false". This
however is already set for all character types, indicating that there is
perhaps an error reading the object_records file in the first place.
> 
> Secondly, the warriors sometimes don't appear at all. Not easy to
> re-produce, but it appears to be linked to some code I added that
> makes them move around, and pick things up. It might be because they
> have an outfit property set with random settler clothes they picked up
> off the ground.
This is certainly possible. I'll have to double check what will happen
here. It shouldn't do anything with the outfit property is there is no
mapping file defined for that model. I have made a few changes to the
cal3d code in sear recently that may also be the cause.
> 
> Thirdly I am getting weird texture issues. Oak trees that look fine at
> great distance (probably when billboarded) but have the default "Sear"
> texture closer. Fir trees that have the default texture when
> billboarded, and at other times the fir trees have a strange blobby
> green texture close up. Any idea what might be going on?
This again seems to suggest some problems with the media config files.
Are there any parse errors or missing files reported?

Simon

> 
> Recent changes should to some extent fix the massive pile of rubbish
> that builds up near the origin, as the warriors now pick it up, though
> until I can work out how to get them to burn it, it will just build up
> in their inventories.
> 
> Al


More information about the General mailing list