[WF-General] Ember help

Erik Hjortsberg erik.hjortsberg at gmail.com
Tue Mar 23 14:57:21 PDT 2010


Ok, I'm pretty sure it's your graphics card.
No matter the error is happening when Ogre is being initialized so 
there's nothing Ember can do.
It should probably be better at reporting the error as being a not 
working 3d card/driver issues.
Without knowing your 3d card type there's not much I can do, more than 
recommend that you see if there are any updated or alternative drivers 
you can use.

/Erik

2010-03-23 14:25, chirag jain skrev:
> here is the link to the ember.log http://pastebin.be/24031
>
> Regards
>
> On Tue, Mar 23, 2010 at 4:30 AM, Erik Hjortsberg 
> <erik.hjortsberg at gmail.com <mailto:erik.hjortsberg at gmail.com>> wrote:
>
>     Hi, could you send your ~/.ember/ember.log file to me?
>     My guess would however be that the OpenGL drivers for your card
>     are broken. Can you run any other 3d applications? What graphics
>     card do you have?
>
>     /Erik
>
>     2010-03-23 13:21, chirag jain skrev:
>>     Hi,
>>
>>     I just successfully installed ember on my Ubuntu 9.10 system.
>>     When I tried to run ember from terminal, it launched successfully
>>     but when I click on accept it just crashed and gave me the
>>     following logs:
>>
>>     chirag at chirag-desktop:~$ ember
>>     According to my calculations Ember should be installed in /usr/bin/..
>>     Starting Ember....
>>     Starting Ember version 0.5.7
>>     Initializing Ember services
>>     Setting home directory to /home/chirag/.ember
>>     ember.bin: ../../../../RenderSystems/GL/src/OgreGLSupport.cpp:57:
>>     virtual void Ogre::GLSupport::initialiseExtensions(): Assertion
>>     `pcVer && "Problems getting GL version string using glGetString"'
>>     failed.
>>     Crashed with signal 6, will try to shut down SDL gracefully.
>>     Please report bugs at https://bugs.launchpad.net/ember
>>     /usr/bin/ember: line 118:  9480 Aborted                
>>     $bindir/ember.bin --home $homedata "$@"
>>
>>     As I am still new with ember, it is quite difficult for me to
>>     resolve the issues from my end. Hoping to get some help.
>>
>>     Regards
>>
>>
>>     On Mon, Mar 22, 2010 at 8:08 AM, Jonathon Doran <jon at doransw.com
>>     <mailto:jon at doransw.com>> wrote:
>>
>>
>>             You can fix that locally by changing /bin/sh to point to
>>             bash. As a long term
>>             fix, scripts that require bash-isms should start with
>>             #!/bin/bash,  but as Erik
>>             said that's Autopackage's bug. :)
>>
>>
>>         Is the package missing the #! line?  If so, I would agree
>>         that is a bug.
>>         But the original message showed the script being ran by
>>         explicitly naming the
>>         (wrong) shell.  I would have preferred a report which
>>         mentioned running
>>         "./package" or similar, rather than overriding the shell on
>>         the command line.
>>
>>
>>         _______________________________________________
>>         General mailing list
>>         General at mail.worldforge.org <mailto:General at mail.worldforge.org>
>>         http://mail.worldforge.org/lists/listinfo/general
>>
>>
>>
>>
>>     -- 
>>     Chirag Jain
>>
>>     Undergraduate Student
>>     Netaji Subash Institute of Technology
>>     New Delhi
>>
>>
>>     _______________________________________________
>>     General mailing list
>>     General at mail.worldforge.org  <mailto:General at mail.worldforge.org>
>>     http://mail.worldforge.org/lists/listinfo/general
>>        
>
>     _______________________________________________
>     General mailing list
>     General at mail.worldforge.org <mailto:General at mail.worldforge.org>
>     http://mail.worldforge.org/lists/listinfo/general
>
>
>
>
> -- 
> Chirag Jain
>
> Undergraduate Student
> Netaji Subash Institute of Technology
> New Delhi
>
>
> _______________________________________________
> General mailing list
> General at mail.worldforge.org
> http://mail.worldforge.org/lists/listinfo/general
>    
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.worldforge.org/pipermail/general/attachments/20100323/7e19cee7/attachment.html>


More information about the General mailing list