[WF-General] Need some help...

Erik Ogenvik erik at ogenvik.org
Fri Jan 9 03:44:18 PST 2015


There's code in both Ember and the Worldforge libraries that uses C++11
features, and thus a compiler that has support for these features is needed.
I don't have an OSX machine myself, so I can't say more than that. Péter
would know more.

/Erik

2015-01-09 11:55 GMT+01:00 Marisa Giancarla <fstltna at me.com>:

> Im not clear on the need to use c++11. Is this a ember requirement or a
> apple requirement? I can pay $150 to get this building for osx, $75 up
> front and $75 when done, if anyone is interested... I have ember running in
> a win8.1vm, but would rather have a native osx port.
>
> Marisa
>
> On Jan 2, 2015, at 2:02 AM, Péter Szücs <peter.szucs.dev at gmail.com> wrote:
>
> Hi!
>
> I have built the last OS X binary. I have messed up adding some macports
> dependencies for the last OS X build, which already got reported.
> I have also tried to update the Mac binaries, but due to new c++11
> requirements, we needed to switch from Apple's GCC 4.2 (last gcc with GPLv2
> license) to clang with libc++.
> Unfortunatelly, when I last tried, I couldnt even build the macports
> packages with clang.
> Check out this:
> http://mail.worldforge.org/pipermail/general/2013-October/007950.html
>
> If you can confirm, that the dependencies are now building with clang and
> libc++, then it may worth a second try.
>
> Peter
>
>
> 2015-01-02 0:55 GMT+01:00 Marisa Giancarla <fstltna at me.com>:
>
>> Ill reply with more info later, but i wanted to ask if you are using the
>> prebuilt client on Yosemite? I wouldnt mind using that but it crashes on my
>> mac...
>>
>> Marisa
>>
>> ----
>> LinkedIn: http://www.linkedin.com/in/marisagiancarla
>> Opensim City: https://OpensimCity.org
>> Opensim Radio: http://radio.opensimcity.org:8188
>> Empire Directory: https://EmpireDirectory.net
>> Lugdunon City: https://LugdunonCity.org
>> IndieDB: http://www.indiedb.com/company/pocketfiction-pocketgames4me
>>
>> On Dec 31, 2014, at 4:27 PM, Sean Ryan <sryan at evercrack.com> wrote:
>>
>> Hi Marisa,
>>
>> I looked at your error and have a couple of comments.
>>
>> First, you should not run ember as root.  It is good unix/linux practice
>> to run as a regular user, and I would strongly suggest that you do that.
>> This is not just for WF stuff, this is for ALL stuff.
>>
>> Second, the issue without looking too deep appears to be a driver.  I did
>> a search of the error, and seems that ubuntu 14.04 may have a problem with
>> that, perhaps all you need is an update and recompile.
>>
>> libGL: Error in /root/.drirc line 2, column 0: no element found.
>> libGL error: failed to load driver: swrast
>>
>>
>> https://answers.launchpad.net/ubuntu/+source/xorg-lts-transitional/+question/259177
>>
>> As a matter of course, you should look at the following things:
>>
>> 1) glxinfo ensure that you have a HARDWARE driver.  For practical linux
>> purposes, this means nothing that says "mesa".  You should see something
>> like AMD, nVidia, or some such.
>>
>> 2) glxgears ... make sure it runs.  If it doesn't run, ember will
>> definitely not run (it usually will though, even with emulation like mesa,
>> so this is just a quick test to see if you have something very seriously
>> wrong with your system setup).
>>
>> The reason for this is that ember uses OGRE, which has hardware
>> requirements.  It will work properly only with a hardware GL (or directx if
>> on windows) driver.
>>
>> You should also post your ember.log, and a backtrace (I think ember has a
>> --debug option that will run through the debugger, you can easily get the
>> backtrace at the point of crashing easily enough ... you can type 'bt' to
>> get it ;)
>>
>> Third, I notice you are running hammer (which would be a dev environment)
>> and the prebuilt ember.  This is problematic depending on your
>> environmental setup.  For example, if you prepend LD_LIBRARY_PATH with the
>> hammer/work/local/lib directory and attempt to run with a prebuilt ... that
>> could work poorly as the dev environment is set to usually pull from the
>> master branch, rather than a specific version.
>>
>> Usually, it's one or the other, not both (there are reasons why you would
>> want to do that potentially, but without understanding the how and why, all
>> I can say is that this should be avoided).
>>
>> Last, for osx and ember.  All I can say is that it's on the list
>> somewhere ... way down at the bottom.  I myself run a mac, and it is a
>> significant dependency chain to unravel.  I personally think that until
>> such time as we are building our stack on osx (and for me, this means using
>> cmake, as auto tools is not very interested in this), this is unlikely.
>>
>> Hope this helps you out, please feel free to ask any questions via the
>> list at any time.
>>
>> Welcome to WorldForge!
>>
>> /Sean
>>
>>
>>
>>
>>
>> On 2014-12-31 13:49, Marisa Giancarla wrote:
>>
>> I need the ember client modified to run on osx yosemite as right now
>>
>> it crashes at startup. Will pay $50 or more for the fix and of course
>>
>> the fix would be made available for other worldforge users.
>>
>> Also i am trying to build the linux client or using the 0.7.2 prebuild
>>
>> version but i get errors when trying to start it. Here is what i am
>>
>> seeing: ember run issues [1] i will pay for help with this too, if
>>
>> that is what it takes...
>>
>> Really like the look of this project and will post about my project
>>
>> when it is farther along...
>>
>> ----
>>
>> LinkedIn: http://www.linkedin.com/in/marisagiancarla [2]
>>
>> Opensim City: https://OpensimCity.org [3]
>>
>> Opensim Radio: http://radio.opensimcity.org:8188 [4]
>>
>> Empire Directory: https://EmpireDirectory.net [5]
>>
>> Lugdunon City: https://LugdunonCity.org [6]
>>
>> IndieDB: http://www.indiedb.com/company/pocketfiction-pocketgames4me
>>
>> [7]
>>
>> Links:
>>
>> ------
>>
>> [1]
>>
>>
>> https://www.evernote.com/shard/s81/sh/70c7126d-f9e7-4e2d-81c7-b1988c1f7ee9/789b1ba31853392f51e9814d856c02a4
>>
>> [2] http://www.linkedin.com/in/marisagiancarla
>>
>> [3] https://OpensimCity.org
>>
>> [4] http://radio.opensimcity.org:8188
>>
>> [5] https://EmpireDirectory.net
>>
>> [6] https://LugdunonCity.org
>>
>> [7] http://www.indiedb.com/company/pocketfiction-pocketgames4me
>>
>> _______________________________________________
>>
>> General mailing list
>>
>> General at mail.worldforge.org
>>
>> http://mail.worldforge.org/lists/listinfo/general
>>
>> _______________________________________________
>> General mailing list
>> General at mail.worldforge.org
>> http://mail.worldforge.org/lists/listinfo/general
>>
>>
>> _______________________________________________
>> General mailing list
>> General at mail.worldforge.org
>> http://mail.worldforge.org/lists/listinfo/general
>>
>>
> _______________________________________________
> General mailing list
> General at mail.worldforge.org
> http://mail.worldforge.org/lists/listinfo/general
>
>
> _______________________________________________
> General mailing list
> General at mail.worldforge.org
> http://mail.worldforge.org/lists/listinfo/general
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.worldforge.org/pipermail/general/attachments/20150109/e8a3eed9/attachment-0001.html>


More information about the General mailing list