[WF-General] Linux issue?

Marisa Giancarla fstltna at me.com
Mon Jan 19 21:29:33 PST 2015


I used the guest extensions, installed with the built-in menu option on the latest virtualbox so they match. It seems to be related to sdl, as it works fine till the 3d graphics start...

Marisa

----
LinkedIn: http://www.linkedin.com/in/marisagiancarla
TinyRPG: http://TinyRPGGame.com
Opensim City: https://OpensimCity.org
Opensim Radio: http://radio.opensimcity.org:8188
Empire Directory: https://EmpireDirectory.net
Lugdunon City: https://LugdunonCity.org
IndieDB: http://www.indiedb.com/company/pocketfiction-pocketgames4me

> On Jan 19, 2015, at 9:18 PM, David Felix <felix.davidj at gmail.com> wrote:
> 
> With 3d accelleration, are you using virtualbox guest additions? If so, how did you install them? Guest additions can be installed from virtual cdrom or via apt. The apt method typically has older, stable guest additions. The virtual cdrom may force a kernel upgrade, but they will match the host virtualbox version. In my experience, the following will work the best:
> 
> * Install guest additions from ubuntu repo, determine version and download older virtualbox host to match version, reboot and import box there.
> * Install guest additions from virtual cdrom and force guest OS to build and upgrade kernel with new module, reboot the guest VM for changes to take effect.
> 
> Mixing and matching will result in odd behavior. If you still believe it's a mouse issue, it's possible that it is the mouse if you're using a Mac magic mouse and virtualbox is exposing a trackpad interface to the guest.
> 
> David J Felix
> (513)-967-3543
> felix.davidj at gmail.com
> 
>> On Fri, Jan 16, 2015 at 9:38 PM, Taben Yaroslav <yaroslav.taben at mail.utoronto.ca> wrote:
>> I also use Ubuntu, except without any issues. Maybe check mouse driver or something? (The one in virtual machine)
>> 
>> 
>> Yaroslav
>> 
>>> On Jan 16, 2015, at 8:53 PM, Marisa Giancarla <fstltna at me.com> wrote:
>>> 
>>> Im using ubuntu 14.04.
>>> 
>>> Marisa
>>> 
>>> ----
>>> LinkedIn: http://www.linkedin.com/in/marisagiancarla
>>> TinyRPG: http://TinyRPGGame.com
>>> Opensim City: https://OpensimCity.org
>>> Opensim Radio: http://radio.opensimcity.org:8188
>>> Empire Directory: https://EmpireDirectory.net
>>> Lugdunon City: https://LugdunonCity.org
>>> IndieDB: http://www.indiedb.com/company/pocketfiction-pocketgames4me
>>> 
>>>> On Jan 16, 2015, at 3:14 PM, Erik Ogenvik <erik at ogenvik.org> wrote:
>>>> 
>>>> That is strange. It does indeed sound like an SDL issue, or something further down the stack. Latest Ember uses SDL2. Tux Racer uses SDL1.
>>>> SDL is however one of the most stable and solid libraries around; if it's reporting incorrect mouse data to Ember it might be that the issue lies further down.
>>>> What Linux distro are you running in your VM? Might be that you'll have more luck with a different one.
>>>> 
>>>> /Erik
>>>> 
>>>> 
>>>> 
>>>> 2015-01-16 22:21 GMT+01:00 Marisa Giancarla <fstltna at me.com>:
>>>>> Looked around but didn't turn anything up. I didn't think that the 3d accel was the cause, just that it seems to occur when 3d mode starts. The first window ember puts up (in github version) works fine. Perhaps it is a sdl issue, as tux racer does the same thing...
>>>>> 
>>>>> Marisa
>>>>> 
>>>>> ----
>>>>> LinkedIn: http://www.linkedin.com/in/marisagiancarla
>>>>> TinyRPG: http://TinyRPGGame.com
>>>>> Opensim City: https://OpensimCity.org
>>>>> Opensim Radio: http://radio.opensimcity.org:8188
>>>>> Empire Directory: https://EmpireDirectory.net
>>>>> Lugdunon City: https://LugdunonCity.org
>>>>> IndieDB: http://www.indiedb.com/company/pocketfiction-pocketgames4me
>>>>> 
>>>>>> On Jan 16, 2015, at 10:03 AM, Taben Yaroslav <yaroslav.taben at mail.utoronto.ca> wrote:
>>>>>> 
>>>>>> I doubt that the mouse issue has anything to do with 3D acceleration. It's just about the input. Did you try to find any articles about this?
>>>>>> 
>>>>>> 
>>>>>> Yaroslav
>>>>>> 
>>>>>>> On Jan 16, 2015, at 12:50 PM, Marisa Giancarla <fstltna at me.com> wrote:
>>>>>>> 
>>>>>>> I added the switch "-j1" to the build command and it compiles ember fine now. Too bad this didn't fix the mouse issue...
>>>>>>> 
>>>>>>> Marisa
>>>>>>> 
>>>>>>> ----
>>>>>>> LinkedIn: http://www.linkedin.com/in/marisagiancarla
>>>>>>> TinyRPG: http://TinyRPGGame.com
>>>>>>> Opensim City: https://OpensimCity.org
>>>>>>> Opensim Radio: http://radio.opensimcity.org:8188
>>>>>>> Empire Directory: https://EmpireDirectory.net
>>>>>>> Lugdunon City: https://LugdunonCity.org
>>>>>>> IndieDB: http://www.indiedb.com/company/pocketfiction-pocketgames4me
>>>>>>> 
>>>>>>>> On Jan 16, 2015, at 4:39 AM, Erik Ogenvik <erik at ogenvik.org> wrote:
>>>>>>>> 
>>>>>>>> What errors are you getting when trying to build it?
>>>>>>>> 
>>>>>>>> /Erik
>>>>>>>> 
>>>>>>>> 2015-01-16 11:33 GMT+01:00 Marisa Giancarla <fstltna at me.com>:
>>>>>>>>> No, it is with the linux ember from the main worldforge website as i cant get it to build on either of my linux installations. Do you have one you could send me? Here is my log file:
>>>>>>>>> Ember Log Output
>>>>>>>>> 
>>>>>>>>> Marisa
>>>>>>>>> ----
>>>>>>>>> LinkedIn: http://www.linkedin.com/in/marisagiancarla
>>>>>>>>> TinyRPG: http://TinyRPGGame.com
>>>>>>>>> Opensim City: https://OpensimCity.org
>>>>>>>>> Opensim Radio: http://radio.opensimcity.org:8188
>>>>>>>>> Empire Directory: https://EmpireDirectory.net
>>>>>>>>> Lugdunon City: https://LugdunonCity.org
>>>>>>>>> IndieDB: http://www.indiedb.com/company/pocketfiction-pocketgames4me
>>>>>>>>> 
>>>>>>>>>> On Jan 16, 2015, at 12:30 AM, Erik Ogenvik <erik at ogenvik.org> wrote:
>>>>>>>>>> 
>>>>>>>>>> Ok, and this is with running the latest version of Ember from Git?
>>>>>>>>>> Could you send me your ~/.ember/ember.log file?
>>>>>>>>>> 
>>>>>>>>>> /Erik
>>>>>>>>>> 
>>>>>>>>>> 2015-01-16 9:08 GMT+01:00 Marisa Giancarla <fstltna at me.com>:
>>>>>>>>>>> Hi. Im using vmware and other game apps seem to work fine. Also the ember screens come up and look ok and ogre correctly uses the renderer as hardware opengl. The ember loading screens and server selection screens appear fine, its just the mouse that is acting wonky once the ember screen comes up...
>>>>>>>>>>> 
>>>>>>>>>>> Marisa
>>>>>>>>>>> 
>>>>>>>>>>> ----
>>>>>>>>>>> LinkedIn: http://www.linkedin.com/in/marisagiancarla
>>>>>>>>>>> TinyRPG: http://TinyRPGGame.com
>>>>>>>>>>> Opensim City: https://OpensimCity.org
>>>>>>>>>>> Opensim Radio: http://radio.opensimcity.org:8188
>>>>>>>>>>> Empire Directory: https://EmpireDirectory.net
>>>>>>>>>>> Lugdunon City: https://LugdunonCity.org
>>>>>>>>>>> IndieDB: http://www.indiedb.com/company/pocketfiction-pocketgames4me
>>>>>>>>>>> 
>>>>>>>>>>>> On Jan 15, 2015, at 11:53 PM, Erik Ogenvik <erik at ogenvik.org> wrote:
>>>>>>>>>>>> 
>>>>>>>>>>>> Running in a virtual machine is problematic, since the 3d acceleration then often isn't handled by the graphic card but instead is done in software by the virtualization engine. And given the very complex nature of 3d graphics these days the software almost never provide enough features to make it work (not to speak of the performance).
>>>>>>>>>>>> 
>>>>>>>>>>>> However, VirtualBox provides experimental support for exposing the native GPU. https://www.virtualbox.org/manual/ch04.html#guestadd-3d
>>>>>>>>>>>> Is this what you're running? 
>>>>>>>>>>>> 
>>>>>>>>>>>> /Erik
>>>>>>>>>>>> 
>>>>>>>>>>>> 2015-01-16 0:22 GMT+01:00 Marisa Giancarla <fstltna at me.com>:
>>>>>>>>>>>>> Im trying to set up a linux vm to test ember, and I'm running into a issue. The first time i ran it a ogre window appeared and asked me what rendering engine i wanted to use. I selected opengl and the ember server selector window appeared. But when i try to move the mouse it goes crazy. Like it jumps between 4 or 5 places vertically and nowhere in-between. Has anyone else seen this?
>>>>>>>>>>>>> 
>>>>>>>>>>>>> Marisa
>>>>>>>>>>>>> 
>>>>>>>>>>>>> ----
>>>>>>>>>>>>> LinkedIn: http://www.linkedin.com/in/marisagiancarla
>>>>>>>>>>>>> TinyRPG: http://TinyRPGGame.com
>>>>>>>>>>>>> Opensim City: https://OpensimCity.org
>>>>>>>>>>>>> Opensim Radio: http://radio.opensimcity.org:8188
>>>>>>>>>>>>> Empire Directory: https://EmpireDirectory.net
>>>>>>>>>>>>> Lugdunon City: https://LugdunonCity.org
>>>>>>>>>>>>> IndieDB: http://www.indiedb.com/company/pocketfiction-pocketgames4me
>>>>>>>>>>>>> 
>>>>>>>>>>>>> _______________________________________________
>>>>>>>>>>>>> General mailing list
>>>>>>>>>>>>> General at mail.worldforge.org
>>>>>>>>>>>>> http://mail.worldforge.org/lists/listinfo/general
>>>>>>>>>>>> 
>>>>>>>>>>>> _______________________________________________
>>>>>>>>>>>> General mailing list
>>>>>>>>>>>> General at mail.worldforge.org
>>>>>>>>>>>> http://mail.worldforge.org/lists/listinfo/general
>>>>>>>>>>> 
>>>>>>>>>>> _______________________________________________
>>>>>>>>>>> General mailing list
>>>>>>>>>>> General at mail.worldforge.org
>>>>>>>>>>> http://mail.worldforge.org/lists/listinfo/general
>>>>>>>>>> 
>>>>>>>>>> _______________________________________________
>>>>>>>>>> General mailing list
>>>>>>>>>> General at mail.worldforge.org
>>>>>>>>>> http://mail.worldforge.org/lists/listinfo/general
>>>>>>>>> 
>>>>>>>>> _______________________________________________
>>>>>>>>> General mailing list
>>>>>>>>> General at mail.worldforge.org
>>>>>>>>> http://mail.worldforge.org/lists/listinfo/general
>>>>>>>> 
>>>>>>>> _______________________________________________
>>>>>>>> General mailing list
>>>>>>>> General at mail.worldforge.org
>>>>>>>> http://mail.worldforge.org/lists/listinfo/general
>>>>>>> _______________________________________________
>>>>>>> General mailing list
>>>>>>> General at mail.worldforge.org
>>>>>>> http://mail.worldforge.org/lists/listinfo/general
>>>>>> _______________________________________________
>>>>>> General mailing list
>>>>>> General at mail.worldforge.org
>>>>>> http://mail.worldforge.org/lists/listinfo/general
>>>>> 
>>>>> _______________________________________________
>>>>> General mailing list
>>>>> General at mail.worldforge.org
>>>>> http://mail.worldforge.org/lists/listinfo/general
>>>> 
>>>> _______________________________________________
>>>> General mailing list
>>>> General at mail.worldforge.org
>>>> http://mail.worldforge.org/lists/listinfo/general
>>> _______________________________________________
>>> General mailing list
>>> General at mail.worldforge.org
>>> http://mail.worldforge.org/lists/listinfo/general
>> 
>> _______________________________________________
>> General mailing list
>> General at mail.worldforge.org
>> http://mail.worldforge.org/lists/listinfo/general
> 
> _______________________________________________
> General mailing list
> General at mail.worldforge.org
> http://mail.worldforge.org/lists/listinfo/general
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.worldforge.org/pipermail/general/attachments/20150119/76f2424d/attachment-0001.html>


More information about the General mailing list