[WF-Infra] Zope-Problems

Tim R Ansell mithro at senet.com.au
Fri Jul 13 15:32:56 PDT 2001


I've checked the script and found out the problem, "0.0" is not equal to
"0" (this feature/bug has accounted for numerous problems in DTML code)
so it accounted has having something in it.. I know a simple fix for
this and will quickly implement it (from something in the time being)..

Mithro


kosh wrote:
> 
> On Thursday 12 July 2001 10:06 am, you wrote:
> > I believe this can be done.  At the bottom, there is some sort of "index
> > number" or something along those lines.  I believe if you set this to 0,
> > the document will not show up on the navigation bar.
> 
> If set to 0 which is default it should not show up. However the script
> checking for that is semi broken right now.
> >
> > At 10:50 PM 7/12/01 +0930, you wrote:
> > >He he, more feature requests...
> > >
> > >The ability to stop a compound document from appearing on the navigation
> > >bar.
> > >
> > >Tim R Ansell wrote:
> > > > 2 Semi important feature requests,
> > > >
> > > > 1. The ability to select a custom style sheet for the current page
> > > > (needed for the Chopping Block)
> > >
> > >(I could most proberly add this feature if you want?)
> > >
> > > > 2. The ability to turn on wrapping of in the text boxes (make editing a
> > > > bit easier :)
> > > >
> > > > Mithro
> > > >
> > > > Tim R Ansell wrote:
> > > > > The image previews also don't appear in the preview section, they
> > > > > appear at the top of the page above the manage tabs.
> > > > >
> > > > > Mithro
> > > > >
> > > > > Tim R Ansell wrote:
> > > > > > I'm also getting this error randomly when trying to create/convert
> > > > > > documents to the WF-Doc profile..
> > > > > >
> > > > > >  <P><STRONG>InvalidObjectReference</STRONG></P>
> > > > > >
> > > > > >   Sorry, a site error occurred.<p>
> > > > > > <!--
> > > > > > Traceback (innermost last):
> > > > > >   File /home/zope/Zope-2.3.3-src/lib/python/ZPublisher/Publish.py,
> > > > > > line 223, in publish_module
> > > > > >   File /home/zope/Zope-2.3.3-src/lib/python/ZPublisher/Publish.py,
> > > > > > line 187, in publish
> > > > > >   File /home/zope/Zope-2.3.3-src/lib/python/Zope/__init__.py, line
> > > > > > 221, in zpublisher_exception_hook
> > > > > >   File /home/zope/Zope-2.3.3-src/lib/python/ZPublisher/Publish.py,
> > > > > > line 175, in publish
> > > > > >   File /home/zope/Zope-2.3.3-src/lib/python/Zope/__init__.py, line
> > > > > > 235, in commit
> > > > > >   File /home/zope/Zope-2.3.3-src/lib/python/ZODB/Transaction.py,
> > > > > > line 300, in commit
> > > > > >   File /home/zope/Zope-2.3.3-src/lib/python/ZODB/Connection.py,
> > > > > > line 375, in commit
> > > > > >     (Info: (('Products.CompoundDoc.inputtext', 'InputText'),
> > > > > > '\000\000\000\000\000\000\201G', ''))
> > > > > > InvalidObjectReference: Attempt to store an object from a foreign
> > > > > > database connection
> > > > > >
> > > > > > -->
> > > > > >
> > > > > > I've had to resort to the copy/paste method...
> > > > > >
> > > > > > Tim R Ansell wrote:
> > > > > > > When trying to edit the new site i ran into these problems...
> > > > > > >
> > > > > > > Edit box for text area is WAY to small, when you goto
> > >
> > > Control-Panel ->
> > >
> > > > > > > Configure and change the width etc you get the following error
> > > > > > >
> > > > > > > Error Type: NameError
> > > > > > > Error Value: keyslist
> > > > > > >
> > > > > > > <!--
> > > > > > > Traceback (innermost last):
> > > > > > >   File
> > >
> > > /home/zope/Zope-2.3.3-src/lib/python/ZPublisher/Publish.py, line
> > >
> > > > > > > 223, in publish_module
> > > > > > >   File
> > >
> > > /home/zope/Zope-2.3.3-src/lib/python/ZPublisher/Publish.py, line
> > >
> > > > > > > 187, in publish
> > > > > > >   File /home/zope/Zope-2.3.3-src/lib/python/Zope/__init__.py,
> > >
> > > line 221,
> > >
> > > > > > > in zpublisher_exception_hook
> > > > > > >     (Object: FrontPage)
> > > > > > >   File
> > >
> > > /home/zope/Zope-2.3.3-src/lib/python/ZPublisher/Publish.py, line
> > >
> > > > > > > 171, in publish
> > > > > > >   File /home/zope/Zope-2.3.3-src/lib/python/ZPublisher/mapply.py,
> > >
> > > line
> > >
> > > > > > > 160, in mapply
> > > > > > >     (Object: config_object)
> > > > > > >   File
> > >
> > > /home/zope/Zope-2.3.3-src/lib/python/ZPublisher/Publish.py, line
> > >
> > > > > > > 112, in call_object
> > > > > > >     (Object: config_object)
> > > > > > >   File
> > >
> > > /home/zope/Zope/lib/python/Products/CompoundDoc/controlpanel.py,
> > >
> > > > > > > line 867, in config_object
> > > > > > >     (Object: FrontPage)
> > > > > > > NameError: (see above)
> > > > > > >
> > > > > > > -->
> > > > > > >
> > > > > > > The tabs at the top of the object are all streched and
> > > > > > > disjointed.
> > > > > > >
> > > > > > > What do profiles do? I can't seem to figure out how to use
> > >
> > > them/how they
> > >
> > > > > > > effect the page. Ocassionaly i can't change the profile to
> > > > > > > WF_Doc, it doesn't give any error but just sits there untill it
> > > > > > > finally returns "NoData" error. Changing Profiles also seems to
> > > > > > > nuke data, there
> > >
> > > should
> > >
> > > > > > > be some warning about this. Can you make the default profile
> > > > > > > WF_Doc?
> > > > > > >
> > > > > > > How do you change the order of stuff?
> > > > > > >
> > > > > > > Thats all the problems i could find for the moment :)
> > > > > > >
> > > > > > > Mithro
> > >
> > >_______________________________________________
> > >Infra mailing list
> > >Infra at mail.worldforge.org
> > >http://mail.worldforge.org/lists/listinfo/infra
> >
> > _______________________________________________
> > Infra mailing list
> > Infra at mail.worldforge.org
> > http://mail.worldforge.org/lists/listinfo/infra
> _______________________________________________
> Infra mailing list
> Infra at mail.worldforge.org
> http://mail.worldforge.org/lists/listinfo/infra



More information about the Infra mailing list